Tuning Locos and the Advanced Tuning Panel

Category : Articles

This article is about the “Advanced Tuning Panel” in the BlueRail App. For the vast majority of users, you just drop your board in and you’re off and running. But electric motors can vary from loco to loco, and its inevitable that there are going to be some locos that need a little additional tuning to the default settings in order to achieve smooth slow speed operation. For this reason, we have included an “Advanced Tuning” panel in the BlueRail app – to allow users to “tweak” slow speed operation. This article is for those people.

So how do you know if your loco needs advanced tuning? Symptoms that you might need advanced tuning are if your loco jiggles a little when traveling at slow speed, or if it starts to roll, then stops.

If the loco is stopping immediately, you’ll also want to read the articles about “measuring you loco’s stall current” and “verifying your motors are isolated from the chassis and the rails“. You can recognize stops related to amperage issues, because they are usually followed by a “cool-down” period, after which a fuse in the board resets itself (or you may have to turn the board off and back on).

You’ll know your loco is stopping because of a tuning issue, because you can immediately run the train again the moment after it stops.

A little technical background, we use Pulse Width Modulation to run the loco motors. This is essentially a sine wave with 16,000 pulses per second. The exact shape of this sine wave is defined by an equation (we’ll call the PID equation), and this equation has 8 variables that dictate the shape of the waves. By adjusting these 8 variables, you can “tune” the shape of the wave to pretty much any motor. At BlueRail we have tuned these 8 variables to values that seem to work for 90% of the locos out there (we call these the default tunings). If you’re loco is jiggling at slow speeds, or starting then stopping (and its not an amperage issue) then it’s time to play with the tunings.

Some of the tuning variables you may be familiar with. Start Voltage is one. Three popular options for Start Voltage (0v, .6v and 1.2v) can be found in the loco settings screen.

Start Voltage simply gives your loco a little extra voltage so it doesn’t take so long to get rolling. Its kind of like “frosting” on the tuning settings, so when diagnosing a tuning issue it’s safest to set the Start Voltage to 0. This is because Start Voltage can cause issues if it is set too high. You can always come back and add some Start Voltage in the end after you are happy with your loco tuning.

The first tuning variable you want to play with (after setting Start Voltage to “0”) is the “Update Period”. The Update Period dictates how often (in milliseconds) that the loco speed is measured and the PID equation gets run. The most popular settings we have found for this are 10ms, 20ms and 35ms. So inside the settings screen you’ll find these 3 options. Try these options, and see if they affect you’re locos initial take-off. If they don’t, it’s time to go to the “Advanced Tuning” panel. To get to the Advanced Tuning panel, go into the loco settings screen and scroll to the bottom till you see “Advanced Tuning”. (The Loco Settings screen is accessed by clicking the “Cog” in the Train Control screen).

Turn on the Advanced Tuning panel (by sliding the toggle). When you return to the Train Control screen, you will see a small “Tuning Fork” button at the left of the screen. Slide that out to access the Advanced Tuning screen. (This screen will look slightly different based on whether you are using Android or iOS.)


Advanced Tuning Panel


In the Advanced Tuning screen, you will see all 8 variables that control the PID equation. You’ll recognize “Start Voltage” and “Update Period” at the top of the panel, displaying the numbers you have selected in the loco settings screen. (Please note Start Voltage is displayed in tenth of 1 volt, so 0v, .6v and 1.2v display as 0, 6 and 12).

To play with the tunings, make sure the Start Voltage is at 0, and begin tweaking the “Update Period” as you run your loco (using the up and down arrows). Try numbers below 10ms and above 35ms, and see how they affect your loco starts. Don’t use values below 0.

If this doesn’t really have any affect, set the Update Period to a middle value (20 ms) and move down to the “Differential” field (second from the bottom). This is the second most common PID variable that can affect slow speed performance. Try setting Differential to “0” and run your train. I have found Bachmann trolleys, N Scale, and some older trains need a setting of “0” to start properly. If that doesn’t work, try setting the Differential higher than the default setting of “.23”. If you CAN find a Differential setting that has a positive impact on your slow speed takeoffs, go back to your “Update Period” and see if you can use it to refine things. If not, you can move on to the other variables (Proportional, Integral and Feed Forward…) to see if you can get any affect from tweaking them.

There is a “Restore Defaults” button in the panel (to bring you back to the original default tunings) so don’t worry about trying different settings.

“Power Factor” acts as a global power multiplier which you might as well leave at 16.

If you DO find tunings that improve the low speed performance of your loco, please email BlueRail with your settings and the type of loco you have. We will add this to our database of presets so future users with the same loco can utilize your settings.

If you feel you have tried everything and still can’t get your loco to start smoothly, there may be one final silver bullet. As I mentioned, the firmware in the board drives the motors at 16,000 times a second (16 kHz). It is also possible to drive motors at a lower frequency: 450 times per second (450 Hz). Electric motors are very forgiving when operating at 450 Hz, and do not need to be tuned so carefully to run smoothly at slow speeds. The down side of 450 Hz is that it does not operate as quietly as 16 kHz, so depending on your loco, it may have a slight hum when the motor runs. If you can live with this hum, most locos will have no problem starting smoothly at 450 Hz PWM.

BlueRail will shortly be adding a 450 Hz firmware option in the app shortly which will give users the choice of running their train at 450 hz.

If you are interested in 450 Hz firmware, please email BlueRail and we will alert you when it is available.

Thank you for your patience and feedback in helping us find the best tunings settings for every model of locomotive on the market. With your help we will add them to the app as presets so future users can avoid having to tune their locos.